Do you support Internet explorer 8 as my browser?

Internet Explorer 8 browser is no longer supported because it is out of date and doesn't support the features required to have a great eCards experience.

Please visit this site to upgrade to a newer version.
http://windows.microsoft.com/en-us/internet-explorer/download-ie

OR

Install Google Chrome

https://www.google.com/intl/en/chrome/browser/

Feedback and Knowledge Base